Campaign Snap - Incident Report: Brief Service Disruption on March 21, 2026 – Incident details

All systems operational

Incident Report: Brief Service Disruption on March 21, 2026

Resolved
Operational
Started about 2 months agoLasted 28 minutes

Affected

Platform

Major outage from 3:00 AM to 3:28 AM

API & Database

Major outage from 3:00 AM to 3:28 AM

Email Service

Major outage from 3:00 AM to 3:28 AM

Background Jobs

Major outage from 3:00 AM to 3:28 AM

Updates
  • Postmortem
    Postmortem

    On March 21, 2026, the Campaign Snap platform experienced a temporary system-wide outage caused by an expired authentication token in our secure internal networking configuration. This prevented backend services from communicating with each other.

    The issue was quickly identified, the token was refreshed, and all services were fully restored. We have since implemented enhanced monitoring with proactive expiration alerts well in advance of any future token renewals.

  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    The Campaign Snap platform is experiencing a system-wide outage.